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What is Excel?  
Microsoft Excel is a spreadsheet program which allows one to enter numerical values or 
data into the rows or columns of a spreadsheet, and to use these numerical entries for such 
things as calculations, graphs, and statistical analysis. Excel is a spreadsheet program that 
allows you to store, organize, and analyze information. . 
 

The Ribbon 
A panel that contains the command buttons and icons, organized into a set of tabs. For example:   
Home tab, Insert tab, Page Layout tab etc. The entire block that stretches from the upper-left side to 
the upper-right side of the application is called the Ribbon. The Ribbon is a unique interface 
component that comprises several task-specific commands grouped under various commands. The 
Ribbon provides the ability to identify desired functions and to perform both simple and advanced 
operations without having to navigate extensively.  

Advantages of using the Ribbon 
The Ribbon makes the features of Excel easily accessible. The distinct presentation of the 
commands on the Ribbon greatly enhances your navigation of the application. Additionally, the 
Microsoft Office Excel Help button available on the Ribbon provides instant access to Excel’s help 
system, allowing you to easily search for information and guidance. 

The Ribbon 
The Ribbon contains multiple tabs, each with several groups of commands. You can add your own 
tabs that contain your favorite commands.  
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Formula Bar: A bar that contains the Name Box, the Formula Box and the Insert Function 
button. The Name Box displays the name of the currently selected cell in a spreadsheet. The 
Formula Box displays the contents of the currently selected cell in a spreadsheet and allows you to 
type the formula or function required. The Insert Function button displays the options to insert a 
function. 
 
Name box: Identifies the cell that is currently selected (i.e. A1 means that your cursor is in Cell A1) 
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Undo/Redo 

Undo feature, just in case you make a mistake. The Undo option is the left curved arrow, 
right at the top of your screen.  

 

Click the left curved arrow to Undo something, and click the right curved arrow to redo it. 
The Undo arrow also a dropdown box. Click the small arrow next to Undo to see the 
following: 

 

This list is for multiple Undo's. Move your mouse down the list and click to undo several 
steps at once.  

 

To Get to Backstage View: 
On the Ribbon, click the File tab.                                                                                                
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Creating and Opening Workbooks 
Excel files are called workbooks. Each workbook holds one or more worksheets (also 
known as "spreadsheets"). 

To Create a New, Blank Workbook: 
1. Click the File tab. This takes you to Backstage view. 

2. Select New. 

3. Select Blank workbook under Available Templates. It will be highlighted by 
default. 

4. Click Create. A new, blank workbook appears in the Excel window. 

Creating a new workbook  
To save time, you can create your document from a template, which you can select 
under Available Templates.. 
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To Open an Existing Workbook: 
1. Click the File tab. This takes you to Backstage view. 

2. Select Open. The Open dialog box appears. 

Opening a workbook  
3. Select your desired workbook and then click Open. 

If you have opened the existing workbook recently, it may be easier to choose Recent 
from the File tab instead of Open to search for your workbook. 

Opening a recent workbook 
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Introduction to Cells and Cell Content 
Cells are the basic building blocks of a worksheet. Cells can contain a variety of content such as text, 
formatting attributes, formulas, and functions. 

Using the Keyboard to Navigate 
 
You can also use the keyboard to navigate to a specific cell, range of cells, or to the end of 
ranges in a worksheet. 

To Move the Active Cell Do This 
One cell at a time to the left, right, up, or 
down. 

Press the corresponding arrow keys. 

To column A of the current row. Press Home. 
Down or up by one screen’s worth of 
rows. 

Press Page Down or Page Up. 

To the right, one cell at a time. Press Tab. 
To the left, one cell at a time. Press Shift+Tab. 
To cell A1 in the active worksheet. Press Ctrl+Home. 
One screen to the left or right, 
respectively. 

Press Alt+Page Up to go left. Press Alt+Page 
Down to go right. 

 

The Cell 
Each rectangle in a worksheet is called a cell. A cell is the intersection of a row and a 
column. 
 
 
Each cell has a name, or a cell address based on which column and row it intersects. The 
cell address of a selected cell appears in the Name box. Here you can see that C5 is 
selected. 
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   Row 5, Column C 
 

 
 

To Select a Cell 
 

1. Click on a cell to select it. When a cell is selected you will notice that 
the borders of the cell appear bold and the column heading and row 
heading of the cell are highlighted. 

2. Release your mouse. The cell will stay selected until you click on another cell in the 
worksheet. 

You can also navigate through your worksheet and select a cell by using the arrow keys on 
your keyboard. 
  

Name Box 

Cell Address 

C6 
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To Select Multiple Cells 
1. Click and drag your mouse until all of the adjoining cells you want are highlighted.  

 

 
Selecting multiple cells  - 3 Rows by 3 Columns 

2. Release your mouse. The cells will stay selected until you click on another cell in the 
worksheet 

 

To Access Formatting Commands by 
Right-Clicking 

Select the cells you want to format. 
Right-click on the selected cells. A dialog box 
will appear where you can easily access many 
commands that are on the ribbon. 

Right-clicking a selected cell 
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To Drag and Drop Cells: 
1. Select the cells that you wish to move.  

2. Position your mouse on one of the outside edges of the selected cells. The mouse 

changes from a white cross to a black cross with 4 arrows .  
 
 
 
 
 
 
 
 

Positioning the mouse to drag and drop cells  
3. Click and drag the cells to the new location. 

4. Release your mouse and the cells will be dropped there. 

Dropped cells  

To Use the Fill Handle to Fill Cells: 
Select the cell or cells containing the content you want to use. You can fill cell content either 
vertically or horizontally.  

Position your mouse over the fill handle so that the white cross becomes a black cross .  

 

 

 

 

 

 
 
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Positioning the mouse to use the fill handle  
 

Click and drag the fill handle until all the cells you want to fill are highlighted. 

Release the mouse and your cells will be filled. 

 
Filled cells 

 

Order of Operations 
 
Please Excuse My Dear Aunt Sally 

Excel calculates formulas based on the following order: 

 Operations enclosed in parentheses 
 Exponential calculations (to the power of) 
 Multiplication and division, whichever comes first 
 Addition and Subtraction, whichever comes first 

 

 

=4/(20-18)*2^2 
 

Perform the operation in parenthesis first: (10-18) = 2 
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=4/2*2^2 
 

Next calculation – the exponents: 2^2= 4 

 

=4/2*4 
 

Division comes before multiplication in this example, so divided: 4/2= 2 

 

=2*4 
 
The last operation is multiplication: 2*4 = 8 

Three types of basic data 
 
In a spreadsheet there are three basic types of data that can be entered: 
 
Labels - (text with no numerical value)  
Constants - (just a number -- constant value)  
 Formulas - (a mathematical equation used to calculate)  
 
data types  examples  descriptions  
LABEL  Name or Wage or 

Days  
anything that is 
just text  

CONSTANT  5 or 3.75 or -7.4  any number  
FORMULA  =5+3 or = 8*5+3  math equation  
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*ALL formulas MUST begin with an equal sign (=).  
 
 
Operands 
Operator  

Name  How to type the 
sign  

Alternative  

+  Addition  Hold down the 
shift key and 
press the Plus 
sign (+) located 
next to the 
backspace  

Press the Plus 
sign (+) located 
on the Num Lock 
keypad section.  

–  Subtraction  Press the dash 
(hyphen “-”) key 
located next to 
the number zero.  

Press the Minus 
sign (-) located 
on the Num Lock 
keypad section.  

*  Multiplication  Hold down the 
shift key and 
press the number 
8 key – the 
asterisk (*)  

Press the asterisk 
(*) key on the 
Num Lock 
keypad  

/  Division  Press the forward 
slash (/) located 
under the 
question mark (?)  

Press the forward 
slash (/) key on 
the Num Lock 
keypad  

Naming Groups of Data 
When working with large amount of data, it is often useful to identify groups of cells that contain 
related data. Instead of specifying the cells individually every time you want to use the data they 
contain, you can define those cells as a range. Whenever you want to use the contents of that range 
in a calculation, you can simply use the name of the range instead of specifying each cell 
individually.  

To create a Name Range: 
1. Select the cells you want to include in your range. 
2. Click the Formulas tab in the Ribbon, and then, in the Define Names group, click Define 

Name to display the New Name dialog box.  
3. In the New Name dialog box, type a name in the Name field, verify that the cells you 

selected appear in the Refers to field, and then click OK.  
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You can also add a comment about the field in the Comment field and select whether you 
want to make the name available for formulas in the entire workbook or just on an 
individual worksheet. 
 

Another way to create a name range is to select the cells you want in the range, click in the Name 
Box next to the Formula bar, and then type the name for the range. You can display the ranges 
available in a workbook by clicking the Name Box down arrow.  
To manage the named ranges in a workbook, display the Formulas tab on the Ribbon and then, in 
the Define Names group, click the Name Manager to display the Name Manager dialog box. 
When you click a named range, Excel 2010 displays the cells it encompasses in the Refers to field. 
Clicking the Edit button displays the Edit Name dialog box, which is a version of the New Name 
dialog box, enabling you to change a named range’s definition. You can also get rid of a name by 
clicking it, clicking the Delete button, and then clicking OK in the confirmation dialog box that 
appears. 
You can also use the names of any ranges you defined to supply values for a formula. For example, if 
the named range NortheastLastDay refers to cells C4:H4, you can calculate the average of cells 
C4:H4 with the formula =AVERAGE(NortheastLastDay).  

If you want to delete a row or a column:  
1. Right-click the row or column head and click Delete.  
2. You can temporarily hide a number of rows or columns by selecting these rows or 

columns and then, on the Home tab, in the Cells group, clicking the Format button, 
pointing to Hide & Unhide, and then clicking either Hide Rows or Hide Columns. 
The rows or columns you selected disappear, but they aren’t gone for good, as they 
would be if you used Delete. Instead they have been removed from display until you 
call them back.  

3. To return the hidden rows to the display, on the Home tab, in the Cells group, click 
the Format button, point to Hide & Unhide, and then click either Unhide Rows or 
Unhide Columns. 

The same way, you can insert individual cells into a worksheet.  
1. To insert a cell, click the cell that is currently in the position where you want the 

new cell to appear.  
2. On the Home tab, in the Cells group, click the Insert button down arrow and then 

click Insert Cells to display the Insert dialog box.  
In the Insert dialog box, you can choose whether to shift the cells surrounding the 
inserted cell down (if your data is arranged as a column) or to the right (if your data 
is arranged as a row). When you click OK, the new cell appears, and the content of 
affected cells shift down or to the right, as appropriate.  
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3. In a similar way, if you want to delete a block of cells, select the cells, and on the 
Home tab, in the Cells group, click the Delete button down arrow and then click 
Delete Cells to display the Delete dialog box—complete with option buttons that 
enable you to choose how to shift the position of the cells around the deleted cells.  

If you want to move the data in a group of cells to another location in 
your worksheet: 

1. Select the cells you want to move and position your mouse pointer on the selection’s 
border.  

2. When the mouse pointer changes to a four-headed arrow, you can drag the selected 
cells to the desired location on the worksheet.  
If the destination cells contain data, Excel 2010displays a dialog box asking if you 
want to overwrite the destination cells’ content. If you want to replace the existing 
values, click the OK button. If you don’t want to overwrite the existing values, click 
the Cancel button and insert the required number of cells to accommodate the data 
you want to move. 

Color the Sheet tabs 
Coloring worksheet tabs can make specific worksheets easier to locate within a large 
workbook.  

Right click the appropriate Sheet tab, select Tab Color, and then select the desired 
color.  
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Wrap Text 

When you type text that is too long to fit in the cell, the text overlaps the next cell. If you do 
not want it to overlap the next cell, you can wrap the text. 

 For example: 

1. In cell A2.  
2. Type Text too long to fit.  
3. Press Enter.  

 

 

 

 

 

 

 

 

 

4. Click on cell A2.  
5. Choose the Home tab.  
6. Click the Wrap Text button 

 Excel wraps the text in the cell.  
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Grouping/Ungrouping Sheets in Excel 2010  
 
Grouping sheets in Excel refers to selection of several sheets within a workbook to work 
with them as a set. This feature helps the user save considerable time when the same 
information will be added to different worksheets in a workbook. By grouping the sheets 
together, the data would have to be typed only on one of the sheets to have them appear in 
the same locations on the other grouped sheets. 
A group of sheets can be created in a workbook by simply selecting the desired sheets with 
the mouse. The title bar is changed to display the word "Group" when more than one sheet 
is selected.  
 
Follow the steps below to select a group of worksheets:  
 

1. Click on the tab of the first sheet to be selected.  
2.  

 
                                  Figure 1: Ungrouped Sheets 
 
 

3. Press and hold Shift.  
4.  Click on the last sheet tab to be included in the group.  
5. You will notice that Sheet tabs will change color. 

 
                               Figure 2: Grouped Sheets 
 
 
To select non-adjacent or non-consecutive sheets, press and hold Ctrl while clicking on the 
desired sheet tabs.  
 
To select all sheets in a workbook, click on any sheet tab using the alternate mouse button, 
and then choose Select All Sheets from the shortcut menu.  
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